HDU - 3342Legal or Not(拓扑排序)

幼敏悟过人,读书辄成诵。这篇文章主要讲述HDU - 3342Legal or Not(拓扑排序)相关的知识,希望能为你提供帮助。
题干:
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not? 

We all know a master can have many prentices and a prentice may have a lot of masters too, its legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xians master and, at the same time, 3xian is HHs master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is Bs master ans B is Cs master, then A is Cs master.
Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 < = N, M < = 100). Then M lines follow, each contains a pair of (x, y) which means x is ys master and y is xs prentice. The input is terminated by N = 0. 
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
Output
For each test case, print in one line the judgement of the messy relationship. 
If it is legal, output "YES", otherwise "NO".
Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output
YES
NO

题目大意:
      给出m对关系A-B,说明A是B的师傅,问输入的关系是否合法。
解题报告:
      并查集是不可以的,因为不是同一种关系。判断有向图是否成环,考虑拓扑排序。
AC代码:
#include< bits/stdc++.h>

using namespace std;
const int MAX = 500 + 5 ;
int n,m;
struct Node
int to;
int w;
int ne;
e[MAX];
int in[MAX],head[MAX],ans[MAX];
int cnt = 0,top = 0;
priority_queue< int,vector< int > ,greater< int> > pq;
bool topu()
//预处理
for(int i = 0; i< n; i++)
if(in[i] == 0) pq.push(i);

while(!pq.empty() )
int cur = pq.top();
pq.pop();
ans[++top] = cur;
for(int i = head[cur]; i!=-1; i=e[i].ne) //是ne啊!!!!
in[e[i].to]--;
if(in[e[i].to] == 0 ) pq.push(e[i].to);


if(top != n) return false;
else return true;

void init()
cnt = 0; top = 0;
memset(in,0,sizeof(in));
memset(head,-1,sizeof(head));
while(!pq.empty() ) pq.pop();

void add(int u,int v,int w)
e[cnt].to = v;
e[cnt].w = w;
e[cnt].ne = head[u];
head[u] = cnt;
cnt++;

int main()


int u,v;
while(~scanf("%d%d",& n,& m) )
if(n == 0) break;
init();
while(m--)
scanf("%d%d",& u,& v);
add(u,v,0);
in[v]++;

if(topu()) puts("YES");
else puts("NO");


return 0 ;

总结:
      i=e[i].ne这句别写错了就行,,别直接用他自动补全的i=e[i].to了。。。
     
【HDU - 3342Legal or Not(拓扑排序)】


    推荐阅读